WP7及WP8应用开发所需环境

WP7系列SDK只支持 VS2010,至少要求Windows Vista

WP8系列SDK只支持 VS2012,里面已经包含了SDK7,且要求操作系统最低是Windows 8

WP7.8 SDK只是一些映像,如果安装了WP7SDK,就会加入到WP7里,如果安装了WP8SDK,就会加入到WP8里。

想要开发WP7应用:

Windows 7下只能用VS2010+sp1,安装WP7SDK;建议安装WP7.1.1补丁及WP7.8映像;
Windows 8下可以用VS2010+sp1或者VS2012,VS2010安装WP7SDK即可,VS2012只需要且只能安装WP8SDK。

要想开发WP8应用:

只能用Windows 8,安装VS2012+sp1及WP8SKD,同时可以开发WP7应用;建议安装WP7.8补丁